Back to overview
Downtime

System under heavy load

Apr 17, 2026 at 9:20am UTC
Affected services
General
Inbox

Resolved
Apr 17, 2026 at 10:18am UTC

System performance should now be returning to normal. We apologise for any inconvenience caused.

Created
Apr 17, 2026 at 9:20am UTC

We're aware of issues where some workspaces are not loading. This is due to increased system load. It should be resolved shortly.