Back to overview
Downtime
Degraded Performance: Inbox
Mar 23, 2026 at 12:34pm UTC
Affected services
Inbox
Resolved
Mar 23, 2026 at 1:04pm UTC
System performance has now returned to normal. We apologise for any inconvenience caused.
Affected services
Created
Mar 23, 2026 at 12:34pm UTC
We are currently investigating reports of slow loading times in the Cue Inbox. You may experience delays when accessing conversations. Our team is actively working to resolve this and we will provide updates as more information becomes available.
Affected services