Back to overview
Downtime

System under heavy load

Nov 13 at 09:50am UTC
Affected services
General
Inbox

Resolved
Nov 13 at 10:04am UTC

System functionality has been restored.

Created
Nov 13 at 09:50am UTC

We're aware and scaling up resources to handle the increased load.