Back to overview
Downtime
Unable to log in to platform
Oct 28 at 08:57am UTC
Affected services
General
Inbox
Resolved
Oct 28 at 09:10am UTC
Access was restored once our systems scaled up automatically. Issue was due to excessive CPU utilisation. Our team is investigating the root cause.
Affected services
Created
Oct 28 at 08:57am UTC
Some customers reported being unable to log in and access the platform.
Affected services