Back to overview
Resolved

System under heavy load

Jun 26, 2026 at 9:27am UTC
Affected services
General
Inbox

Resolved
Jun 26, 2026 at 4:57pm UTC

Event queues have now cleared and real-time updates should be working in the inbox again normally. Our apologies for the disruption today. We'll be sharing a root cause analysis and future mitigation plan early next week.

Updated
Jun 26, 2026 at 3:15pm UTC

Update: A few more mitigations are being deployed shortly. We will be monitoring for signs of resolution.

Updated
Jun 26, 2026 at 1:41pm UTC

Update: The changes made have not mitigated the growth of our real-time event queues from sending updates to the UI. We are still investigating.

Updated
Jun 26, 2026 at 12:33pm UTC

We are still receiving reports from customers who are experiencing intermittent issues. We have deployed fixes, increased server capacity and co-ordinated with high-volume customers to reduce their traffic. We expect performance issues to subside from this point and will post further updates.

Updated
Jun 26, 2026 at 11:30am UTC

System availability is returning to normal.

Updated
Jun 26, 2026 at 9:44am UTC

Issue has been identified and mitigation is being put in place to restore system availability.

Updated
Jun 26, 2026 at 9:35am UTC

Load issues have resurfaced. Our team is investigating and will post updates.

Updated
Jun 26, 2026 at 9:30am UTC

System has recovered automatically. We are continuing to investigate and monitor closely.

Created
Jun 26, 2026 at 9:27am UTC

We are investigating and working to resolve. We'll post more information soon.