Back to overview
Resolved
System under heavy load
Jun 24, 2026 at 8:00am UTC
Affected services
General
Inbox
Resolved
Jun 24, 2026 at 8:21am UTC
This issue has now been resolved.
Affected services
Created
Jun 24, 2026 at 8:00am UTC
We are investigating and working to resolve. We'll post more information soon.
Affected services