WhatsApp and Facebook Message Delivery Disruption
Resolved
Jun 12, 2026 at 5:18pm UTC
Meta has now updated their status page to say that issues affecting their Cloud API have now been resolved: https://metastatus.com/whatsapp-business-api
Affected services
Updated
Jun 12, 2026 at 4:15pm UTC
Meta seems to be having a significant outage at the moment.
More information: https://metastatus.com/whatsapp-business-api
Affected services
Updated
Jun 12, 2026 at 3:07pm UTC
Our upstream provider has identified the cause of the issue and initial mitigations have been put in place. We are monitoring with them closely and will advise of any new developments as soon as possible.
Affected services
Created
Jun 12, 2026 at 2:15pm UTC
We are currently experiencing a disruption affecting the delivery of WhatsApp and Facebook Messenger messages, caused by an issue with an upstream provider. As a result, some messages may not be sending or receiving, and automated flows may not be triggering. Incoming messages are being queued and will be delivered once the issue is resolved.
Affected services