Back to overview
Maintenance

Infrastructure Update

Jun 10, 2026 at 8:00pm UTC  –  Jun 10, 2026 at 9:00pm UTC
Affected services
General

Resolved
Jun 10, 2026 at 9:00pm UTC

Maintenance ended

Created
Jun 10, 2026 at 8:00pm UTC

We will be performing scheduled maintenance on Wednesday, 10 June 2026 at 22:00 SAST (UTC+2) to roll out infrastructure improvements to the Cue platform. No downtime is expected during this update and all platform features will continue to work normally.