Back to overview
Downtime
Inbox not loading
Jun 3, 2026 at 2:23pm UTC
Affected services
Inbox
Resolved
Jun 3, 2026 at 3:02pm UTC
System performance is now improving.
Affected services
Updated
Jun 3, 2026 at 2:41pm UTC
Performance issues are still persisting. Team is investigating.
Affected services
Updated
Jun 3, 2026 at 2:34pm UTC
System performance is now returning to normal.
Affected services
Created
Jun 3, 2026 at 2:23pm UTC
We're aware of an issue where the conversations inbox is not loading for customers. We are investigating and will post an update as soon as we know more.
Affected services