Back to overview
Degraded
Live chat impacted
May 20, 2026 at 6:20am UTC
Affected services
Inbox
Resolved
May 20, 2026 at 9:52am UTC
System performance has returned to normal, we apologise for any inconvenience caused.
Affected services
Created
May 20, 2026 at 6:20am UTC
Agents experiencing issues responding to tickets. Our dev team is investigating.
Affected services