Back to overview
Downtime
Message delays
May 19, 2026 at 5:16pm UTC
Affected services
General
Inbox
Resolved
May 19, 2026 at 7:07pm UTC
Queues should now be clearing.
Affected services
Updated
May 19, 2026 at 6:45pm UTC
We have identified the root cause as a customer that is making excessive duplicate requests to our API causing upstream rate limiting issues. We are working with the customer to rectify the situation which should then allow the queues to finish processing.
Affected services
Created
May 19, 2026 at 5:16pm UTC
We are experiencing a backlog in message processing queues. Our team is actively investigating the issue. We will update with more information as soon as possible.
Affected services