System under heavy load
Resolved
Nov 18 at 09:51am UTC
Incident report
On Monday 17th November 2025, the Cue platform became unavailable to all users. A database had become unresponsive to a number of core services due to severe load issues, rendering the platform inoperable for approximately 2h 50mins between 7:15AM SAST until 10:05 AM SAST.
An optimisation introduced last week resulted in our tickets service suddenly receiving a massive increase in the number of calls to an inefficient database query - this was introduced by a new bulk operation added to an upstream service in order to make indexing operations more efficient so that the platform could better handle the recent increase in large broadcasts being sent.
Outbound and inbound messaging was partly operational during this time, however flows would not have been able to create/manage tickets and some data may have gone out of sync.
The endpoint being used in our tickets service has been replaced with a more efficient and appropriate endpoint so that the optimisations upstream could be put back in place.
Data is being reviewed and synchronised to ensure no further disruptions are experienced.
We apologise for the disruption caused. If you have any further issues please contact us at support@cuedesk.com.
Affected services
Updated
Nov 17 at 07:40am UTC
Fix has been implemented and system performance should start to return to normal now. Our sincere apologies for the Monday morning interruption. A full incident report will follow.
Affected services
Updated
Nov 17 at 07:13am UTC
We have identified the root cause and are working on a fix. Login is now working but the loading and sending of messages in conversations may still be affected. We'll post another update as soon as we have more information.
Affected services
Created
Nov 17 at 05:42am UTC
We’re having some trouble with login. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services