Back to overview
Downtime
Inbox is not loading
Apr 14 at 07:51am UTC
Affected services
Inbox
Resolved
Apr 14 at 08:01am UTC
We have identified the issue and it has been resolved.
Affected services
Inbox
Created
Apr 14 at 07:51am UTC
We are aware that the Inbox is not loading and looking into it.
Affected services
Inbox