Back to overview
Downtime
Users are unable to login
Nov 25 at 07:00am UTC
Affected services
Inbox
Resolved
Nov 25 at 08:44am UTC
This has now been resolved.
Affected services
Updated
Nov 25 at 07:07am UTC
Service has been restored some tickets are taking longer than usual to load. Initial investigation suggests our database was overwhelmed possibly due to month end traffic. Increasing database capacity has restored services. We are investigating further.
Affected services
Created
Nov 25 at 07:00am UTC
We've received reports that when trying to access app.cuedesk.com users are receiving an error screen.
Affected services