Back to overview
Resolved
System under heavy load
Aug 31, 2026 at 7:24am UTC
Affected services
General
Inbox
Resolved
Aug 31, 2026 at 8:27am UTC
System performance should be stable now. Thank you for bearing with us. Root cause analysis to follow.
Affected services
Created
Aug 31, 2026 at 7:24am UTC
Our team is aware and investigating. Updates will be posted shortly.
Affected services