Back to overview
Resolved

Platform Improvements

Aug 18, 2026 at 5:00pm UTC  –  Aug 18, 2026 at 6:00pm UTC
Affected services
General
Inbox

Resolved
Aug 18, 2026 at 6:00pm UTC

Maintenance ended

Created
Aug 18, 2026 at 5:00pm UTC

We will be performing scheduled maintenance on Tuesday, 18 August 2026 at 19:00 SAST (UTC+2) to make a number of improvements across the platform, including fixes to inbox search and contact handling.